Написать программу, которая для трёхзначного числа, если оно четное, то возводит в квадрат, а если нечётное, то находит сумму цифр.

Написать программу, которая для трёхзначного числа, если оно четное, то возводит в квадрат, а если нечётное, то находит сумму цифр.
Гость
Ответ(ы) на вопрос:
Гость
var a:integer; begin readln(a); if a mod 2 = 0 then writeln(a*a) else writeln((a div 100) + (a mod 10) + ((a mod 100) div 10)); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы