Написать программу которая по вводу с клавиатуры трех действительных чисел выводит на экран сообщение о том могут ли они являться сторонами треугольника
Написать программу которая по вводу с клавиатуры трех действительных чисел выводит на экран сообщение о том могут ли они являться сторонами треугольника
Ответ(ы) на вопрос:
Нужно воспользоваться свойством треугольников:
Любая сторона треугольника меньше суммы двух других сторон и больше их разности .
---------------------------------------------------Pascal--------------------------------------------------
Var a,b,c:integer;
begin
readln(a,b,c);
if (ab-c) and (ba-c) and (cb-a) then
writeln('Yes')
else
writeln('No');
end.
Не нашли ответ?
Похожие вопросы