Написать программу, которая получает на вход число произвольной длины меньше, чем 9 знаков и показывает, какие в нем повторяющиеся цифры БЫСТРЕЕ!11! Мог не правильно понять вопрос, напишите хоть что-нибудь похожее ,срочно нужно
Написать программу, которая получает на вход число произвольной длины меньше, чем 9 знаков и показывает, какие в нем повторяющиеся цифры
БЫСТРЕЕ!11! Мог не правильно понять вопрос, напишите хоть что-нибудь похожее ,срочно нужно
Ответ(ы) на вопрос:
var i,n,k: integer;
a: array[0..9] of integer;
begin
write('число: '); readln(n);
for i:=0 to 9 do a[i]:=0;
while n>0 do
begin
k:=n mod 10;
a[k]:=a[k]+1;
n:=n div 10;
end;
for i:=0 to 9 do
if a[i]>1 then writeln('повторяющаяся цифра: ',i);
end.
число: 1022315
повторяющаяся цифра: 1
повторяющаяся цифра: 2
Не нашли ответ?
Похожие вопросы