Написать программу на языке паскаль, возведение числа в степень. Степень вводится с клавиатуры.
Написать программу на языке паскаль, возведение числа в степень. Степень вводится с клавиатуры.
Ответ(ы) на вопрос:
Гость
Возведение вещественного числа x в натуральную степень n (без использования стандартных функций):
var n,i:integer; x,xn:real;
begin
write('x = ');
readln(x);
write('n = ');
readln(n);
xn:=1;
for i:=1 to n do xn:=xn*x;
writeln('xn = ',xn:6:3);
end.
Пример:
x = 2
n = 5
xn = 32
Гость
Только степень вводится с клавы:
Var
P:integer;
St:real;
Begin
Write('Показатель степени(целое число) = ');ReadLn(P);
St:=1;
For P:= 1 to P do
St:=St*2;
WriteLn('2^',P,' = ',St);
End.
Пример:
Показатель степени(целое число) = 4
2^4 = 16
Степень и число вводится с клавы:
Var
P:integer;
St,O:real;
Begin
Write('Показатель степени(целое число) = ');ReadLn(P);
Write('Основание степени(вещественное число) = ');ReadLn(O);
St:=1;
For P:= 1 to P do
St:=St*O;
WriteLn(O,'^',P,' = ',St);
End.
Пример:
Показатель степени(целое число) = 3
Основание степени(вещественное число) = 2.5
2.5^3 = 15.625
Не нашли ответ?
Похожие вопросы