Написать программу на языке Си для вычисления значений следующих выражений: a=5, c=5 a=a+b-2 c=c+1, d=c-a+d a=a*c, c=c-1 a=a/10, c=c/2, b=b-1, d=d*(c+b+a) Выражения, записанные в одной строке, записывать одним оператором-выраже...
Написать программу на языке Си для вычисления значений следующих выражений:
a=5, c=5
a=a+b-2
c=c+1, d=c-a+d
a=a*c, c=c-1
a=a/10, c=c/2, b=b-1, d=d*(c+b+a)
Выражения, записанные в одной строке, записывать одним оператором-выражением. Переменные c и d объявить как целые, переменные a и b – как вещественные. Значения переменных b и d вводить с клавиатуры. После вычисления каждого выражения выводить на экран значения всех переменных.
Ответ(ы) на вопрос:
я конечно не особо программист, но это вроде работает
#include
int main(){
float a=5,c=5;
int b,d;
printf("Здравствуйте!Введите 2 числа:\n");
scanf("%d",&b); scanf("%d",&d);
a += b-2;
d += c-a-1;
a = a*c-1;
a = a/10;
c = c/2;
b--;
d = d*(c+b+a);
printf("В итоге получилось:%F,%F,%d,%d",&a,&b,&c,&d);
return 0;
}
Не нашли ответ?
Похожие вопросы