Написать программу перевода из десятичной системы счисления в двоичную при помощи функций пользователя. Паскаль(Функции пользователя).
Написать программу перевода из десятичной системы счисления в двоичную при помощи функций пользователя. Паскаль(Функции пользователя).
Ответ(ы) на вопрос:
Гость
Program n1;
var n: integer;
function per(n: integer ): integer;
var
a: array[1..500] of integer;
i,c:integer;
begin
c:= 0;
repeat
c:= c + 1;
a[c]:= n mod 2;
n:= n div 2;
until n = 0;
for i:= c downto 1 do
write(a[i]);
end;
begin
write('введите число: ');
readln(n);
per(n);
end.
Не нашли ответ?
Похожие вопросы