Написать программу перевода целого десятичного числа в двоичную систему диапозон значения до 1000. На языке Паскаль.

Написать программу перевода целого десятичного числа в двоичную систему диапозон значения до 1000. На языке Паскаль.
Гость
Ответ(ы) на вопрос:
Гость
PascalABC.Net var    a : integer;    s : string;  begin  readln (a);    while a>=1 do    begin      if a mod 2 = 1 then      s := s + '1'      else        s := s + '0';      a := a div 2;    end    else  s := '0';  s := ReverseString (s);  writeln (s);  end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы