Написать программу по задаче: Автомат получает на вход четырехзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа -сумма двух старших и сумма двух младш...
Написать программу по задаче: Автомат получает на вход четырехзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам. 1. Вычисляются два числа -сумма двух старших и сумма двух младших разрядов. 2. Полученные два числа записываются друг за другом в порядке невозрастания (без разделителей).
Ответ(ы) на вопрос:
Гость
Var
A,B:integer;
Begin
ReadLn(A);
B:=(A div 1000) + ((A div 100) mod 10);
A:=((A div 10) mod 10)+ (A mod 10);
if A>=B then Write(B,A)
else if B>=A then Write(B,A)
End.
Не нашли ответ?
Похожие вопросы