Написать программу, подсчитывающую количество четных и нечетных цифр в четырехзначном числе . ( в паскале с использованием цикла for)
Написать программу, подсчитывающую количество четных и нечетных цифр в четырехзначном числе . ( в паскале с использованием цикла for)
Ответ(ы) на вопрос:
var a,b1,b2,c,i:integer;
begin
readln(a);
for i:=1 to 4 do begin
c:=a mod 10;
if c mod 2 = 0 then b1+=1 else
b2+=1;
a:=a div 10;
end;
writeln('Четных - ',b1,' нечетных - ',b2);
end.
Не нашли ответ?
Похожие вопросы