Написать программу в Паскале Ввести натуральное число N и вычислить сумму всех чисел Фибоначчи, меньших N. Предусмотрите защиту от ввода отрицательного числа N. Пример: Введите число N: 10000 Сумма 17709

Написать программу в Паскале Ввести натуральное число N и вычислить сумму всех чисел Фибоначчи, меньших N. Предусмотрите защиту от ввода отрицательного числа N. Пример: Введите число N: 10000 Сумма 17709
Гость
Ответ(ы) на вопрос:
Гость
Var A,B,N:integer; S:real; Begin A:=0; B:=1; Write('N = '); ReadLn(N); if N<0 then Write('Введите положительное число') else    Begin    While A0. n = ');  readln(n);  end; f1:=1; f2:=1; fn:=f1+f2; while fn