Написать программу,которая определяет ,что введено с клавиатуры( русская прописная или строчня буква ,английская прописная или строчная буква ,цифра или символ) Написать программу ,которая определяет ,к какой четверти координа...

Написать программу,которая определяет ,что введено с клавиатуры( русская прописная или строчня буква ,английская прописная или строчная буква ,цифра или символ) Написать программу ,которая определяет ,к какой четверти координатной плоскости принадлежит точка. Координаты точки вводятся с клавиатуры .Написать все эти 2 программы в Pascal ) Помогите срочно пожалуйста )
Гость
Ответ(ы) на вопрос:
Гость
//1 begin var ch:=readchar ('Введите символ: '); if ch in ['A'..'z', 'А'..'я'] then begin if upcase(ch)=ch then write ('Прописная ') else write ('Строчная '); if ch in ['A'..'z'] then write ('английская ') else write ('русская '); write ('буква'); end else if ch in ['0'..'9'] then write ('Цифра') else write ('Символ'); end. //2 begin var x:=readreal ('Ведите координаты точки: '); var y:=readreal; if (x=0) and (y=0) then write ('Точка лежит на начале координат') else if x=0 then writeln ('Точка лежит на оси ординат') else if y=0 then writeln ('Точка лежит на оси абсцисс') else if x>0 then if y>0 then write (1) else write (4) else if y>0 then write (2) else write (3); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы