Написать программы для Pascal ABC, срочно! 1.Написать программу организации, заполнения и вывода на экран массива, содержащего среднесуточную температуру воздуха за неделю 2.генерируются 2 случайных натуральных двузначных числа...
Написать программы для Pascal ABC, срочно!
1.Написать программу организации, заполнения и вывода на экран массива, содержащего среднесуточную температуру воздуха за неделю
2.генерируются 2 случайных натуральных двузначных числа. Найти их сумму, разность большего и меньшего и произведение
3.Написать программу заполнения одномерного массива десятью случайными целыми числами из промежутка [7,25]
Ответ(ы) на вопрос:
Гость
1.
const n=7;
var a:array[1..n] of integer;
i:integer;
begin
Randomize;
writeln('Температура за неделю:');
for i:=1 to n do begin
a[i]:=random(21)-30;
write(a[i]:5);
end;
writeln;
end.
Пример:
Температура за неделю:
-13 -20 -14 -25 -26 -30 -17
2.
var a,b:integer;
begin
a:=random(90)+10;
b:=random(90)+10;
writeln('a = ',a,' b = ',b);
writeln('Сумма = ',a+b);
writeln('Разность = ',abs(a-b));
writeln('Произведение = ',a*b);
end.
Пример:
a = 11 b = 38
Сумма = 49
Разность = 27
Произведение = 418
3.
const n=10;
var a:array[1..n] of integer;
i:integer;
begin
Randomize;
for i:=1 to n do begin
a[i]:=random(19)+7;
write(a[i]:3);
end;
writeln;
end.
Пример:
24 21 25 7 24 16 18 21 14 25
Гость
вот тебе все одной программой.
var num,i,srtemp,x,y:integer;
temp:array[1..7] of integer;
mass:array[1..10] of integer;
begin
writeln('введите номер программы 1/2/3');
write('номер программы - ');
readln(num);
srtemp:=0;
randomize;
if num=1 then begin
writeln('');
writeln('программа для посчета средней недельной температуры');
writeln('пожалуйста, введите средние температуры каждого дня недели');
for i:=1 to 7 do begin readln(temp[i]);
srtemp:=temp[i]+srtemp;
end;
writeln('средняя температура =',(srtemp div 7));
end;
if num=2 then begin writeln('');
writeln('программа для посчета суммы, разности большего и меньшего и их произведения');
x:=random(90)+10;
y:=random(90)+10;
writeln('первое число =',x);
writeln('второе число =',y);
writeln('сумма =',x+y);
if x>y then writeln('разность меньшего и большего =',y-x) else writeln('разность меньшего и большего =',x-y);
writeln('произведение =',x*y);
end;
if num=3 then begin
for i:=1 to 10 do
begin
mass[i]:=random(19)+7;
writeln('элемент массива номер ',i,' равен ',mass[i]);
end;
end;
end.
Не нашли ответ?
Похожие вопросы