Напишите программу, которая заполняет массив из N элементов случайными целыми чис
Напишите программу, которая заполняет массив из N элементов случайными целыми числами в диапазоне [ A , B ] и определяет максимальный среди чётных положительных элементов этого массива.
Входные данные
Входная строка содержит три числа: границы диапазона случайных чисел A и B , а также размер массива N . Все числа разделены пробелами. Гарантируется, что 0 < N ≤ 10000 .
Выходные данные
В первой строке программа должна вывести N элементов построенного массива, разделив их пробелами, а во второй строке – максимальный из чётных положительных элементов этого массива. Если в массиве нет таких элементов, программа должна вывести число -1.
B Паскале
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.1, сборка 1204 от 24.03.2016
begin
var n,a,b:integer;
Read(a,b,n);
var mas:=ArrRandom(n,a,b); mas.Println;
var s:=mas.Where(x->x.IsEven and (x>0));
if s.Any then Writeln(s.Max)
else Writeln(-1)
end.
Тестовые решения:
-10 100 20
52 57 39 5 52 40 94 -2 -7 24 65 -6 22 77 2 41 48 83 19 69
94
-10 -2 8
-6 -9 -2 -8 -3 -9 -4 -7
-1
Не нашли ответ?
Похожие вопросы