Напишите программу, которая запрашивает у пользователя числа до тех пор, пока каж?
Напишите программу, которая запрашивает у пользователя числа до тех пор, пока каж??ое следующее число больше предыдущего. В конце программа сообщает, сколько чисел было введено.
в с++. Желательно с объяснениями, пропустил пару прост))
Ответ(ы) на вопрос:
Гость
//Dev-C++ 5.11
#include <iostream>
using namespace std;
int main(void)
{int n1,n2,count=1;
cin>>n1;
n2=n1;
while(n2<=n1)
{n1=n2;
cin>>n2;
count++;} cout<<count; return 0;} Пример ввода: 2 2 1 3 Пример вывода: 4
cin>>n1;
n2=n1;
while(n2<=n1)
{n1=n2;
cin>>n2;
count++;} cout<<count; return 0;} Пример ввода: 2 2 1 3 Пример вывода: 4
Не нашли ответ?
Похожие вопросы