Напишите программу которая из n случайных чисел находио и выводит четырехзначные числа и их произведения у которых квадрат первой цифры меньше квадрата последней цифры числа .Числа задаются из диапозона от 500 до 5000

Напишите программу которая из n случайных чисел находио и выводит четырехзначные числа и их произведения у которых квадрат первой цифры меньше квадрата последней цифры числа .Числа задаются из диапозона от 500 до 5000
Гость
Ответ(ы) на вопрос:
Гость
program long;  uses Crt;  const n=5;  type Vec=array [1..n] of integer;  var A, B, C: Vec;      i,j,k, Col: integer;      Pro: longint;      a1, a2: integer; begin  ClrScr;  Randomize;  Col:=1;  Pro:=1;  WriteLn ('Massiv A:');  for i:=1 to n do    begin      A[i]:=500+random(2000);      Write(A[i]:6);      if A[i] >1000 then         begin           B[Col]:=A[i]; Col:=Col+1;         end;    end;  WriteLn;  Col:=Col-1;  WriteLn;  WriteLn ('Massiv B:');  for i:=1 to Col do    WriteLn(B[i]);  WriteLn;  k:=1;  for i:=1 to n do    begin        a2:=B[i] mod 10;        a1:=B[i] div 1000;        if sqr(a1)50) then Write('Неверное К')   else begin     p:=1;     Writeln('Отобранные случайные числа на интервале [1000;5000]');     for i:=1 to k do     begin       n:=Random(4501)+500; { диапазон [500;5000] }       if n>=1000 then         if (n div 1000)<(n mod 10) then         begin Write(n:5); p:=p*n end;     end;     Writeln;     if p>1 then Writeln('Произведение отобранных чисел равно ',p)     else Writeln('К сожалению, отобранных чисел нет')   end  end. Тестовые решения: Введите количество чисел К (1..50): 15 Отобранные случайные числа на интервале [500;5000]  3208 4925 1279 2528 1637 4979 3536 4416 2116 3655 Произведение отобранных чисел равно 5.02832546192399E+34 Введите количество чисел К (1..50): 3 Отобранные случайные числа на интервале [500;5000]  3385 1177 Произведение отобранных чисел равно 3984145 Введите количество чисел К (1..50): 1 Отобранные случайные числа на интервале [500;5000]  3838 Произведение отобранных чисел равно 3838 Введите количество чисел К (1..50): 1 Отобранные случайные числа на интервале [500;5000] К сожалению, отобранных чисел нет
Не нашли ответ?
Ответить на вопрос
Похожие вопросы