Напишите программу, которая вычисляет факториал натурального числа N ( 1 ≤ N ≤ 10000 ), сохранив все значащие цифры. Факториалом называется произведение всех натуральных чисел от 1 до N : N ! = 1·2·3... ( N - 1)· N .

Напишите программу, которая вычисляет факториал натурального числа N ( 1 ≤ N ≤ 10000 ), сохранив все значащие цифры. Факториалом называется произведение всех натуральных чисел от 1 до N : N ! = 1·2·3... ( N - 1)· N .
Гость
Ответ(ы) на вопрос:
Гость
Program n1; var n, i: integer; p: real; begin write('Введите n: '); readln(n); if (n>=1) and (n<=10000) then begin p := 1; for i := 2 to n do p := p * i; writeln(n, '! = ', p); end; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы