Напишите программу, находящую сумму арифметической прогрессии по заданным значениям первого элемента, разности и количества элементов последовательности.
Напишите программу, находящую сумму арифметической прогрессии по заданным значениям первого элемента, разности и количества элементов последовательности.
Ответ(ы) на вопрос:
1. Вспомним формулу для нахождения суммы арифметической прогрессии:
[latex] S_{n} = \frac{2a_{1}+(n-1)*d}{2} * n[/latex]
Где а - это первый элемент последовательности
n - количество элементов
d -разность.
Составим программу на языке СИ
#include
#include
#include
int a,n,d;
double y;
int main(void)
{
printf("a=");
scanf("%d", &a);
printf("n=");
scanf("%d", &n);
printf("d=");
scanf("%d", &d);
y=((2*a+(n-1)*d)/2.0)*n;
printf("%lf", y);
}
Не нашли ответ?
Похожие вопросы