Напишите программу, определяющую количество и сумму элементов массива целых случайных чисел, больших 50 и меньших 60.

Напишите программу, определяющую количество и сумму элементов массива целых случайных чисел, больших 50 и меньших 60.
Гость
Ответ(ы) на вопрос:
Гость
const   nn=100; var   n,i,k,s:integer;   a:array[1..nn] of integer; begin   Write('Количество элементов в массиве: '); Read(n);   Randomize;   Writeln('Сформированный массив');   k:=0; s:=0;   for i:=1 to n do begin     a[i]:=Random(100);     Write(a[i],' ');     if (a[i] in [51..59]) then begin s:=s+a[i]; Inc(k) end     end;   Writeln;   Writeln('На интервале [51..59] найдено элементов - ',k);   Writeln('Их сумма равна ',s) end. Пример выполнения программы Количество элементов в массиве: 20 Сформированный массив 26 65 64 80 46 0 54 38 63 14 63 81 40 42 17 16 23 88 61 54 На интервале [51..59] найдено элементов - 2 Их сумма равна 108 Замечание Если конструкция a[i] in [51..59] кажется незнакомой, её можно заменить на более длинную и менее эффективную (a[i]>50) and (a[i]<60)
Не нашли ответ?
Ответить на вопрос
Похожие вопросы