Напишите программу (pascal) Найти сумму вводимых с клавиатуры чисел, которые отрицательные.
Напишите программу (pascal)
Найти сумму вводимых с клавиатуры чисел, которые отрицательные.
Ответ(ы) на вопрос:
Гость
Program n1;
var sum,a: integer;
begin
sum:=0;
repeat
readln(a);
if a<0 then sum:=sum+a;
until (a=0);
writeln(sum);
end.
Гость
// PascalABC.NET 3.2, сборка 1385 от 14.02.2017
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('Сумма отрицательных чисел равна ',
ReadSeqRealWhile('Ввод завершайте нулём:',x->x<>0).Where(x->x<0).Sum)
end.
Пример
Ввод завершайте нулём: 2.5 -4 -6.25 5.143 11 -8 0
Сумма отрицательных чисел равна -18.25
Не нашли ответ?
Похожие вопросы