Напишите программу в Паскаль, которая получает день и номер месяца, а выводит количество дней, оставшихся до Нового Года. Считайте, что год невисокосный (365 дней). Учтите, что слово "дней" может иметь также формы "день" и "дня...

Напишите программу в Паскаль, которая получает день и номер месяца, а выводит количество дней, оставшихся до Нового Года. Считайте, что год невисокосный (365 дней). Учтите, что слово "дней" может иметь также формы "день" и "дня". Пример: Введите день и месяц: 25 12 Осталось 7 дней до Нового Года. Пример: Введите день и месяц: 1 1 Осталось 364 дня до Нового Года. Пример: Введите день и месяц: 31 2 Неверная дата.
Гость
Ответ(ы) на вопрос:
Гость
//PascalABC Uses System; var day, month: integer; begin   Read(day, month);    var d := new DateTime(DateTime.Now.Year, month, day);    var new_year := new DateTime(d.Year+1, 1, 1);    Writeln((new_year - d).TotalDays);  end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы