Напишите программу в PaskalABC , которая в последовательности натуральных чисел определяет максимальное чётное число. Программа получает на вход количество чисел в последовательности , а затем сами числа . В последовательности ...
Напишите программу в PaskalABC , которая в последовательности натуральных чисел определяет максимальное чётное число.
Программа получает на вход количество чисел в последовательности , а затем сами числа . В последовательности всегда имеется чётное число. Количество чисел не превышает 1000. Введённые числа не превышают 30000.Программа должна вывести одно число-максимальное чётное число .
Пример работы программы :
Входные данные :3,10,99,42
Выходные данные:42
Ответ(ы) на вопрос:
Гость
Var
N,A,M:word;
Begin
Read(N);
M:=0;
For N:=1 to N do
Begin
Read(A);
if (A>M)and(A mod 2 = 0) then M:=A;
End;
Write(M)
End.
Не нашли ответ?
Похожие вопросы