Напишите программы для следующих задач, организуя экран пользователя по предложенному варианту. Задача 1:Написать программу вычисления площади поверхности параллелепипеда. S=2*(A*B+B*C+C*A) Введите данные А=9,В=7.5,С=5 Экран п...
Напишите программы для следующих задач, организуя экран пользователя по предложенному варианту.
Задача 1:Написать программу вычисления площади поверхности параллелепипеда.
S=2*(A*B+B*C+C*A)
Введите данные А=9,В=7.5,С=5
Экран пользователя:Вычислите S поверхности параллелепипеда.
Введите исходные данные:
Длина(см)? 9
Ширина(см)? 7.5
Высота(см)? 5
Площадь поверхности: 30000 кв.см.
Задача 2: Записать программу вычисления стоимости покупки, состоящей из нескольких тетрадей и карандашей.
Экран пользователя: Вычисление стоимости покупки
Введите исходные данные:
Цена тетради(руб.)? 2.75
Количество тетрадей? 5
Цена карандашей(руб.)? 0.85
Количество карандашей? 2
Стоимость покупки: 15.45 руб.
Ответ(ы) на вопрос:
program p1;
var
a, b, c, s: real;
begin
Writeln('Вычислите S поверхности параллелепипеда.');
Writeln('Введите исходные данные:');
Write('Длина(см)? '); Readln(a);
Write('Ширина(см)? '); Readln(b);
Write('Высота(см)? '); Readln(c);
s := 2 * (a * b + b * c + c * a);
Writeln('Площадь поверхности: ', s, ' кв.см.')
end.
Тестовое решение:
Вычислите S поверхности параллелепипеда.
Введите исходные данные:
Длина(см)? 9
Ширина(см)? 7.5
Высота(см)? 5
Площадь поверхности: 300 кв.см.
program p2;
var
ct,ck,s:real;
kt,kk:integer;
begin
Writeln('Вычисление стоимости покупки');
Writeln('Введите исходные данные:');
Write('Цена тетради(руб.)? '); Readln(ct);
Write('Количество тетрадей? '); Readln(kt);
Write('Цена карандашей(руб.)? '); Readln(ck);
Write('Количество карандашей? '); Readln(kk);
s:=ct*kt+ck*kk;
Writeln('Стоимость покупки: ',s:0:2,' руб.')
end.
Тестовое решение:
Вычисление стоимости покупки
Введите исходные данные:
Цена тетради(руб.)? 2.75
Количество тетрадей? 5
Цена карандашей(руб.)? 0.85
Количество карандашей? 2
Стоимость покупки: 15.45 руб.
Не нашли ответ?
Похожие вопросы