Народ, кто разбирается в Pascal ABS помогите с этими задачами: 1. Написать программу, считающее среднее арифметическое цифр числа. 2. Написать программу, считающее сумму цифр кратных "3" числа. 2а. Написать программу, находящую...

Народ, кто разбирается в Pascal ABS помогите с этими задачами: 1. Написать программу, считающее среднее арифметическое цифр числа. 2. Написать программу, считающее сумму цифр кратных "3" числа. 2а. Написать программу, находящую минимальную цифру в числе. Заранее спасибо!
Гость
Ответ(ы) на вопрос:
Гость
Var A,S,n:integer; Begin WriteLn('Введите целое число'); ReadLn(A); S:=0; n:=0; While A<>0 do    Begin    S:=S+A mod 10;    n:=n+1;    A:= A div 10    End; WriteLn('Sr = ',S/n); End. Var A,S:integer; Begin WriteLn('Введите целое число'); ReadLn(A); S:=0; While A<>0 do    Begin    if (A mod 10) mod 3 = 0 then S:=S+A mod 10;    A:=A div 10    End; WriteLn('S = ',S); End. Var A,m:integer; Begin WriteLn('Введите целое число'); ReadLn(A); m:=9; While A<>0 do    Begin    if A mod 10 < m then m:= A mod 10;    A:=A div 10    End; WriteLn('Min = ',m); End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы