Нужно составить программу с помощью Repeat,определяющую максимальное из всех введённых вами чисел.(Пусть признаком конца ввода чисел является введённое число 0).
Нужно составить программу с помощью Repeat,определяющую максимальное из всех введённых вами чисел.(Пусть признаком конца ввода чисел является введённое число 0).
Ответ(ы) на вопрос:
var
i, e : Integer;
begin Writeln('Вводите числа:'); i := 0;
repeat
Readln(e);
if e > i then i := e;
until e = 0;
Writeln('Наибольшее число: ', i);
end.
Program abc; uses crt; const n=30; var a:array[1..n] of integer; i, max:integer; begin clrscr; for i:=1 to n do read(a[i]); max:=a[1]; for i:=2ton do if a[i]>max then max:=a[i]; write('max=',max); end.
Не нашли ответ?
Похожие вопросы