Паскаль! Срочно!1)Написать программу, которая из заданного одномерного массива размерности N выводит только те элементы, значения которых принадлежат отрезку [c,d]. 2)Дан массив действительных чисел B[N]. Сформировать из него н...

Паскаль! Срочно! 1)Написать программу, которая из заданного одномерного массива размерности N выводит только те элементы, значения которых принадлежат отрезку [c,d].  2)Дан массив действительных чисел B[N]. Сформировать из него новый массив C[N], выбросив из него максимальные элементы.Пример Массив B: 2 3 5 8 5 2 8 5 4 8 Массив C: 2 3 5 5 2 5 4  
Гость
Ответ(ы) на вопрос:
Гость
1)  var i,n:integer;      c,d:integer;      a:array[1..1000] of integer;     begin write('введите c,d,n'); read(c,d,n); for i:=1 to n do begin a[i]:=random(100); write(a[i],' '); end; for i:=1 to n do begin if (a[i]>=c) and (a[i]<=d) then write(a[i],' '); end; end. 2) по ссылке на файл
Не нашли ответ?
Ответить на вопрос
Похожие вопросы