Подскажите пожалуйста. (Для программы Кумир и Паскаль) Написать программу в процессе выполнения которой, получить случайное трехзначное число и вывести через запятую его отдельные цифры. Пример: Получено число 123. Его цифры 1,...
Подскажите пожалуйста. (Для программы Кумир и Паскаль)
Написать программу в процессе выполнения которой, получить случайное трехзначное число и вывести через запятую его отдельные цифры. Пример:
Получено число 123.
Его цифры 1, 2, 3.
Примечание: используйте функцию irand, операции div и mod.
Ответ(ы) на вопрос:
Гость
Решение на паскале:
//PascalABC.NET
//NaaMan
var
n,i:integer;
r,c,s:string;
begin
randomize;
n:=random(100,999);
writeln('Сгенерированное число > ', n);
s:=','; r:='.'; c:='';
for i:=1 to 3 do begin
if (i=3) then s:='';
str(n mod 10,c);
r:=concat(s,c,r);
n:=n div 10;
end;
writeln(r)
end.
Не нашли ответ?
Похожие вопросы