Помогите исправить ошибку в коде PASCAL. ПОЖАЛУЙСТА. Заполнить файл f целыми числами, полученными с помощью генератора случайных чисел. Переписать их в файл g в обратном порядке. var f:file of integer; n,i,a,k,b:integer; begin...
Помогите исправить ошибку в коде PASCAL. ПОЖАЛУЙСТА.
Заполнить файл f целыми числами, полученными с помощью генератора случайных чисел. Переписать их в файл g в обратном порядке.
var f:file of integer;
n,i,a,k,b:integer;
begin
randomize;
assign(f,'file1');
rewrite(f);
write('Сколько чисел ввести в файл n=');
readln(n);
for i:=1 to n do
begin
a:=random(50);
write(f,a);
end;
reset(f);
writeln('Исходный файл: ');
while not eof(f) do
begin
read(f,a);
write(a:4);
end;
writeln;
close(f);
reset(f);
for i:=0 to filesize(f) div 2 do{считаем до середины} //filesize - Возвращает текущий размер файла. ФУНКЦИЯ В ПАСКАЛЕ
begin
seek(f,i);{смотрим число в начале}
read(f,a);
seek(f,filesize(f)-i-1);{смотрим число в конце} // seek - Перемещает текущий указатель позиции файла на определенный компонент. ПРОЦЕДУРА В ПАСКАЛЕ
read(f,b);
seek(f,i); {с конца пишем в начало}
write(f,b);
seek(f,filesize(f)-i-1); {с начала пишем в конец}
write(f,a);
end;
close(f);
reset(f);
writeln('Преобразованный файл: ');
while not eof(f) do
begin
read(f,a);
write(a:4);
end;
writeln;
close(f);
end.
Ответ(ы) на вопрос:
Гость
Исправьте одну строку:
for i:=0 to (filesize(f) div 2)-1 do
Не нашли ответ?
Похожие вопросы