Помогите написать программу!!! Дан целочисленный массив M из 15 элементов. Элементы массива могут принимать целые значения от -500 до 500 и вводятся с клавиатуры. Найти и вывести: 1. Сумму квадратов отрицательных элементов. Га...

Помогите написать программу!!! Дан целочисленный массив M из 15 элементов. Элементы массива могут принимать целые значения от -500 до 500 и вводятся с клавиатуры. Найти и вывести: 1. Сумму квадратов отрицательных элементов. Гарантируется, что в исходном массиве есть хотя бы один отрицательный элемент. 2. Произведение элементов массива, имеющих четное значение и стоящих на четных местах. Гарантируется, что в исходном массиве есть хотя бы один такой элемент. 3. Количество элементов массива, превосходящих по модулю 100. Гарантируется, что в исходном массиве есть хотя бы один такой элемент.
Гость
Ответ(ы) на вопрос:
Гость
const maxn=15; var a: array[1..maxn] of integer;     skv,prod,gr,i: integer; begin   writeln('введите ',maxn,' чисел');   skv:=0;  prod:=1;   gr:=0;   for i:=1 to maxn do   begin     write(i,': ');  readln(a[i]);     if a[i]<0 then skv:=skv+a[i]*a[i];     if (a[i] mod 2 = 0) and (i mod 2 = 0) then        prod:=prod*a[i];     if abs(a[i])>100 then gr:=gr+1;   end;   writeln('сумма квадратов отрицательных:  ',skv);   writeln('произведение четных на четных местах:  ',prod);   writeln('больше 100 по модулю:  ',gr); end. введите 15 чисел 1: 151 2: -231 3: 104 4: 19 5: 36 6: -112 7: 5 8: 8 9: 11 10: 13 11: 45 12: 5 13: 6 14: 17 15: 19 сумма квадратов отрицательных:  65905 произведение четных на четных местах:  -896 больше 100 по модулю:  4
Не нашли ответ?
Ответить на вопрос
Похожие вопросы