Помогите написать программу на языке Pascal, используя цикл While: Последовательность Фибоначчи определяется так: φ0=0, φ1=1, ..., φn=φn-1+φn-2. По данному числу n определите n-е число Фибоначчи φn.
Помогите написать программу на языке Pascal, используя цикл While:
Последовательность Фибоначчи определяется так:
φ0=0, φ1=1, ..., φn=φn-1+φn-2.
По данному числу n определите n-е число Фибоначчи φn.
Ответ(ы) на вопрос:
Гость
//PascalABC.Net 3.2
begin
var n:=readinteger('n =');
var f1:=0; var f2:=1; var i:=1;
while (i<>n) do
begin
f2+=f1;
f1:=f2-f1;
inc (i);
end;
write (f2);
end.
Не нашли ответ?
Похожие вопросы