Помогите написать программу (Паскаль. массив)
Помогите написать программу (Паскаль. массив)
Ответ(ы) на вопрос:
Program n1;
const n=10;
var a: array[1..n] of integer;
b: array[1..5] of integer;
i,sum,d,k: integer;
begin
sum:=0;
writeln('исходный массив: ');
for i:=1 to n do
begin
a[i]:=i*i;
write(a[i],' ');
end;
writeln;
for i:=1 to n do sum:=sum+a[i];
d:=a[n]-a[1];
k:=0;
for i:=1 to n do if i mod 2=0 then begin
k:=k+1;
b[k]:=a[i];
end;
writeln('сумма: ',sum);
writeln('разность: ',d);
writeln('другой массив: ');
for i:=1 to 5 do write(b[i],' ');
end.
Не нашли ответ?
Похожие вопросы