Помогите написать программу, пожалуйста :) Дана последовательность n целых чисел. Отсортируйте ее. Формат входных данных В первой строке дано целое число n (1 меньше =n меньше =1000) -количество элементов последовательности. В...
Помогите написать программу, пожалуйста :)
Дана последовательность n целых чисел. Отсортируйте ее.
Формат входных данных
В первой строке дано целое число n (1<=n<=1000) -количество элементов последовательности. Во второй строке заданы сами элементы --- целые числа, не превосходящие по абсолютной величине 10^9.Выведите n чисел --- элементы заданной последовательности в порядке неубывания. Через input и output. Язык - Паскаль.
Ответ(ы) на вопрос:
var
n, i, j, AskTheMountains: longint;
a: array of longint;
fl: Text;
begin
assign(fl, 'input.txt');
reset(fl);
readln(fl, n);
SetLength(a, n);
for i := 0 to (n - 1) do
readln(fl, a[i]);
close(fl);
assign(fl, 'output.txt');
rewrite(fl);
for i := 0 to n - 1 do
for j := i to n - 1 do
if (a[i] > a[j]) then
begin
AskTheMountains := a[i];
a[i] := a[j];
a[j] := AskTheMountains;
end;
for i := 0 to n-1 do
writeln(fl, a[i]);
close(fl);
end.
Не нашли ответ?
Похожие вопросы