Помогите!!!! Напишите программу,которая в последовательности натуральных чисел определяет количество трехзначных чисел,кратных 4.Программа получает на вход натуральные числа,количество введенных чисел,неизвестно,последовательно...

Помогите!!!! Напишите программу,которая в последовательности натуральных чисел определяет количество трехзначных чисел,кратных 4.Программа получает на вход натуральные числа,количество введенных чисел,неизвестно,последовательность чисел заканчивается числом 0 (0-признак окончания ввода,не входит в последовательность).Количество чисел не превышает 1000.Введенные числа не превышают 30000.Программа должна вывести одно число:количество трехзначных чисел,кратных 4. (Паскаль)
Гость
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.2, сборка 1411 от 23.03.2017 // Внимание! Если программа не работает, обновите версию! begin   Write(ReadSeqIntegerWhile(k->k<>0).       Where(k->(k>99) and (k<1000) and (k mod 4=0)).Count) end. Пример 45 244 1043 463 500 241 18 44 0 2
Гость
Var A,k:integer; Begin k:=0; Repeat Read(A); if (A>99)and(A<1000)and(A mod 4 = 0) then k:=k+1 Until A = 0; WriteLn(k); End.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы