Помогите,пожалуйста,очень срочно! Написать программу организующую сортировку вы?

Помогите,пожалуйста,очень срочно! Написать программу организующую сортировку вы??ора. Процедуру использовать только для сортировки!
Гость
Ответ(ы) на вопрос:
Гость
Const n = 10; type arr=array[1..n] of byte; procedure sort(var a:arr); var i, j, max, imax:integer; begin j := n; while j > 1 do begin     max := a[1];     imax := 1;     for i := 2 to j do         if a[i] > max then begin             max := a[i];             imax := i         end;     a[imax] := a[j];     a[j] := max;     j := j - 1  end; end; var a: arr; i: byte;   begin Randomize; writeln('Исходный массив:'); for i := 1 to n do    begin   a[i] := random(256);   write(a[i]:4)   end; writeln; sort(a); writeln('Отсортированный массив:'); for i := 1 to n do write(a[i]:4); writeln; end. Пример: Исходный массив:  119 239 156 143  34 184  93  19 218 120 Отсортированный массив:   19  34  93 119 120 143 156 184 218 239
Не нашли ответ?
Ответить на вопрос
Похожие вопросы