Помогите пожалуйста, буду очень признателен. Код на C++: Написать программу, которая читает с клавиатуры строку символов, преобразует ее и выводит результат на дисплей. Подсчитать количество слов в строке.

Помогите пожалуйста, буду очень признателен. Код на C++: Написать программу, которая читает с клавиатуры строку символов, преобразует ее и выводит результат на дисплей. Подсчитать количество слов в строке.
Гость
Ответ(ы) на вопрос:
Гость
#include #include using namespace std;  int main(){    string str;    getline(cin,str); //вводим поток в строку    stringstream ss(str); //вводим строку в поток, при этом пробел делит слова на отдельные элементы    int i(0); //счётчик    while(ss>>str) //пока можно выводить элементы(слова)     i++;    cout << i;    cin.get();    cin.get();    return 0; }
Не нашли ответ?
Ответить на вопрос
Похожие вопросы