ПОМОГИТЕ ПОЖАЛУЙСТА Дано 2 целых положительных числа: a и b. Требуется написать программу, которая находит цифру, на которую оканчивается число a^b. Входные данные Результат a=2 b=4 6
ПОМОГИТЕ ПОЖАЛУЙСТА
Дано 2 целых положительных числа: a и b. Требуется написать программу, которая находит цифру, на которую оканчивается число a^b.
Входные данные
Результат
a=2
b=4
6
Ответ(ы) на вопрос:
Гость
Var A,B,C:integer;
Begin
assign(input,'input.txt');
reset(input);
assgin(output,'outpt');
rewrite(output);
C:=1;
Write('A = ');ReadLn(A);
Write('B = ');ReadLn(B);
For B:= 1 to B do
C:=C*A;
WriteLn(C mod 10);
End.
Гость
Var A,B,St:integer;
Begin
Write('A = ');
ReadLn(A);
Write('B = ');
ReadLn(B);
St:=1;
For B:= 1 to B do
St:=St*A;
Write(St mod 10)
End.
Не нашли ответ?
Похожие вопросы