ПОМОГИТЕ, ПОЖАЛУЙСТА! ЛЁГКАЯ ЗАДАЧА ПО ПАСКАЛЮ!Составьте программу, которая позволяет заменить в строке s слово t1 на слово t2. Строку s и слова t1 и t2 введите с клавиатуры. Пример ввода: На небе появилась туча. туча луна Прим...
ПОМОГИТЕ, ПОЖАЛУЙСТА! ЛЁГКАЯ ЗАДАЧА ПО ПАСКАЛЮ!Составьте программу, которая позволяет заменить в строке s слово t1 на слово t2. Строку s и слова t1 и t2 введите с клавиатуры.
Пример ввода:
На небе появилась туча.
туча
луна
Пример вывода:
На небе появилась луна.
Ответ(ы) на вопрос:
Гость
var
s, t1, t2, st: string;
i: integer;
begin
readln(s);
readln(t1);
readln(t2);
if pos(t1, s) <> 0 then
i := pos(t1, s);
st := copy(s, 1, i - 1);
st := st + t2;
st := st + copy(s, i + length(t1), length(s));
writeln(st);
readln;
end.
Не нашли ответ?
Похожие вопросы