Помогите, пожалуйста! Написать программу на языке Pascal для решения любого квадратного уравнения.

Помогите, пожалуйста! Написать программу на языке Pascal для решения любого квадратного уравнения.
Гость
Ответ(ы) на вопрос:
Гость
Var a,b,c,x1,x2,d:integer; begin   ReadLn(a,b,c):   if a=0 then     Writeln('Уравнение не квадратное')   else   begin   d:=sprt(b*b-4*a*c);   if d<0 then     WriteLn('Корней нет')   else if d=0 then     x1:=(-1*b)/(2*a);     WriteLn(x1)   else if d>0 then     x1:=(-1*b-d)/(2*a);     x2:=(-1*d+d)/(2*a);     WriteLn(x1,' ',x2);   end; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы