Помогите пожалуйста. Нужно составить программу, вычисляющую сумму чисел четырехзначного числа.

Помогите пожалуйста. Нужно составить программу, вычисляющую сумму чисел четырехзначного числа.
Гость
Ответ(ы) на вопрос:
Гость
var x,z,sum:integer; i:byte; begin readln(x); sum:=0; for i:=1 to 4 do begin z:=x mod 10; sum:=sum+z; x:=x div 10;end; writeln(sum);readln; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы