Помогите пожалуйста составить программу на ''Pascal ABC'') Дана строка, содержащая текст на русском языке, и некоторая буква. Подсчитать, сколько слов начинается с указанной буквы.
Помогите пожалуйста составить программу на ''Pascal ABC'')
Дана строка, содержащая текст на русском языке, и некоторая буква. Подсчитать, сколько слов начинается с указанной буквы.
Ответ(ы) на вопрос:
Гость
var s:string;i,f,l:integer;a:string;
begin
readln(s);
read(a)
;f:=0;
l:=length(s);
for i:=l downto 1 do
begin
if s[i]=' ' then
if s[i+1]='a' then f:=f+1;
end;
if s[1]='a' then f:=f+1;
writeln(f);
end.
Не нашли ответ?
Похожие вопросы