Помогите пожалуйста составить программы :) 1.Введено четырехзначное число. Найти сумму цифр, кратных 3-м. 2.Определить, сколько среди заданных чисел A, B, C, D отрицательных. 3.Составить программу, которая выводит меню и при н...

Помогите пожалуйста составить программы :) 1.Введено четырехзначное число. Найти сумму цифр, кратных 3-м. 2.Определить, сколько среди заданных чисел A, B, C, D отрицательных. 3.Составить программу, которая выводит меню и при нажатии нужной цифры вычисляет соответствующее выражение: 1 - y= x3 + x 2 - y= (x +1)2 3 - y= sqr(x+4)
Гость
Ответ(ы) на вопрос:
Гость
1) var a:array [1..4] of integer; var x,i,i1: integer; begin writeln('Введите 4-х значное число'); read(x); for i:=1 to 4 do begin a[i]:=x mod 10; if a[i] mod 3 = 0 then begin i1:=i1+a[i]; end; x:=x div 10; end; write(i1); end. 2) Немного не понял: var a:array [1..4] of integer; var i,n,y: integer; begin n:=1; for i:=1 to 4 do begin writeln('Введите ',n, ' число'); read(a[i]); if a[i]<0 then y:=y+1; n:=n+1; end; write('Отрицательных чисел: ',y); end. 3) var i,y,x: integer; begin writeln('Выберите действие: 1)y=x^3 + x; 2)y=(x+1)^2; 3)y=sqr(x+4)'); read(i); if i=1 then begin writeln('Введите x'); read(x); write('y=',(x*x*x)+x); end else begin if i=2 then begin writeln('Введите x'); read(x); write('y=',(x+1)*(x+1)); end else begin if i=3 then begin writeln('Введите x'); read(x); write('y=',sqrt(x+4)); end; end; end; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы