Помогите, пожалуйста. в паскале. пусть в массиве содержатся результаты измерений температуры воздуха за декабрь, которые проводились ежедневно. определите сколько дней в декабре температура была выше средней.
Помогите, пожалуйста. в паскале. пусть в массиве содержатся результаты измерений температуры воздуха за декабрь, которые проводились ежедневно. определите сколько дней в декабре температура была выше средней.
Ответ(ы) на вопрос:
Гость
const d = 31;
var
a: array[1..d] of integer;
i, count, mdl: integer;
begin
for i := 1 to d do begin
a[i] := random(31);
write(a[i], ' ');
mdl := mdl + a[i];
end;
writeln;
writeln('Средняя температура: ', (mdl / d):0:2);
for i := 1 to d do
if(a[i] > mdl / d) then inc(count);
writeln('Дни, в которые температура была выше средней: ', count);
end.
Не нашли ответ?
Похожие вопросы