Помогите, пожалуйста!Напишите программу (с циклом for) для вычисления суммы 1+1/x+1/x^2+1/x^3 + 1/x^4 +... + 1/x^k для любого x.

Помогите, пожалуйста! Напишите программу (с циклом for) для вычисления суммы 1+1/x+1/x^2+1/x^3 + 1/x^4 +... + 1/x^k для любого x.
Гость
Ответ(ы) на вопрос:
Гость
Program BiFi; Var x,a,s:real; k,i:integer; Begin readln(x); readln(k); s:=0; a:=x; for i:=1 to k do begin a:=a/x;                       s:=s+a; writeln(s:6:3); readln; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы