Помогите с информатикой ( Пожалуйста, с блок схемами и самой программой) 1.Предположим, фирма заработала какую-то сумму денег- эту сумму запросите у пользователя. По законодательству из этой суммы следует перечислить в налог 23...
Помогите с информатикой ( Пожалуйста, с блок схемами и самой программой)
1.Предположим, фирма заработала какую-то сумму денег- эту сумму запросите у пользователя. По законодательству из этой суммы следует перечислить в налог 23%. Далее 39% идет на зарплату. Составьте программу, которая рассчитает, какую сумму получит пользователь после выплаты всех налогов и зарплаты.
2. Составьте программу, которая позволит для любых заданных дробных чисел ( их нужно запросить у пользователя) найти их целые части, сумму этих целых частей.
3. Составьте программу, которая по заданным сторонам треугольника( их нужно запросить у пользователя) определяет его площадь. Напомню, что площадь можно вычислить по формуле Герона S= квадратный корень от (p*(p-a)*(p-b)*(p-c)), где p- полупериметр, a,b,c- стороны треугольника, которые надо запросить. Результат выведите с двумя знаками после запятой.
Ответ(ы) на вопрос:
Гость
{1}
var
n: integer;
begin
write ('Введите заработанную сумму: ');
readln (n);
write ('Вы получите: ', (n*0.77)*0.61)
end.
{2}
var
a: array of double;
n, i: byte;
sum: longint;
begin
write ('Введите кол-во дробных чисел: ');
readln (n);
setLength (a, n);
for i:=0 to n-1 do
begin
write ('Введите ', i+1, ' число: ');
readln (a[i]);
end;
for i:=0 to n-1 do
begin
writeln ('Целая часть ', i+1, ' числа: ', trunc(a[i]));
inc (sum, trunc(a[i]));
end;
write ('Сумма целых частей: ', sum);
end.
{3}
var
a, b, c, p: double;
begin
write ('Введите стороны треугольника: ');
readln (a, b, c);
if (a>=(b+c)) or (b>=(a+c)) or (c>=(b+a)) or (a<=0) or (b<=0) or (c<=0) then
write ('Такой треугольник не существует')
else begin
p:=(a+b+c)/2;
write ('Его S = ', sqrt (p*(p-a)*(p-b)*(p-c)):7:2, ' ед^2' );
end;
end.
Не нашли ответ?
Похожие вопросы