Помогите с программой в Паскале, пожалуйста!! Дан массив из N чисел. Определить количество чисел, превышающих число 5. Найти сумму этих чисел.Напишите программу.. (одномерный массив)
Помогите с программой в Паскале, пожалуйста!!
Дан массив из N чисел. Определить количество чисел, превышающих число 5. Найти сумму этих чисел.
Напишите программу.. (одномерный массив)
Ответ(ы) на вопрос:
program arr;
var
ar : array[1..100] of Integer;
i, size, count, sum : Integer;
begin
Writeln('Введите размер массива');
Readln(size);
if (size > 100) then begin
Writeln('Hазмер массива превышает 100 элементов. Программа будет завершена...');
Readln;
end
else begin
Writeln('Введите ', size, ' чисел');
for i:=1 to size do begin
readln(ar[i]);
if ar[i] > 5 then begin
Inc(count);
Inc(sum, ar[i]);
end;
end;
Writeln('Вы ввели ', i - 1, ' чисел из которых ', count, ' больше 5, а их сумма составляет ', sum);
Readln;
end;
end.
Не нашли ответ?
Похожие вопросы