ПОМОГИТЕ СДЕЛАТЬ ! Напишите программу,которая в последовательности целых чисел определяет количество четных чисел кратных 3.Программа получает на выход целые числа .количество введенных чисел неизвестно ,последовательность чи...
ПОМОГИТЕ СДЕЛАТЬ ! Напишите программу,которая в последовательности целых чисел определяет количество четных чисел кратных 3.Программа получает на выход целые числа
.количество введенных чисел неизвестно ,последовательность чисел заканчивается числом 0 (0-признак окончания ввода,не входит в последовательность ).Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30 000. Программа должна вывести одно число: количество четных чисел,кратных 3
ПОМОГИТЕ СДЕЛАТЬ ??
Ответ(ы) на вопрос:
program a1;
var c,k,a: integer;
begin
a:=1;
while (a<>0) and (c<2) do
begin
read(a);
if (ABS(a)<30000) and (a<>0) then
if ((a mod 2) = 0) and ((a mod 3)=0) then inc(k);
inc(c);
end;
writeln('kol = ',k);
end
Не нашли ответ?
Похожие вопросы