Помогите составить программу!пожалуйста!!!!ооочень надоракета запускается с земли со скоростью V(км час) в направлении движения земли по орбите вокруг солнца. составить программу,определяющую результат запуска ракета в зависимо...

Помогите составить программу!пожалуйста!!!!ооочень надо ракета запускается с земли со скоростью V(км час) в направлении движения земли по орбите вокруг солнца. составить программу,определяющую результат запуска ракета в зависимости от скорости V. Известно,что при V16,4 ракета покинет солнечную систему.
Гость
Ответ(ы) на вопрос:
Гость
var v:real; begin write('Введите скорость в км/c: '); readln(v); if v<7.9 then   writeln('Ракета упадет на Землю'); if v=7.9 then   writeln('Ракета будет двигаться вокруг Земли по круговой орбите'); if (v>7.9) and (v<11.2) then   writeln('Ракета будет двигаться вокруг Земли по эллиптической орбите'); if v=11.2 then   writeln('Ракета будет двигаться вокруг Солнца по круговой орбите'); if (v>11.2) and (v<16.4) then   writeln('Ракета будет двигаться вокруг Солнца по эллиптической орбите'); if v>16.4 then writeln('Ракета покинет Солнечную систему'); end.
Гость
Решение на VB Sub Rocket()     Dim x As Single     x = InputBox("Введите скорость ракеты в км/с")     Select Case x     Case Is < 7.91         MsgBox "Ракета упадет на Землю"     Case 7.91         MsgBox "Ракета будет вращаться вокруг Земли по круговой орбите"     Case Is < 11.2         MsgBox "Ракета будет вращаться вокруг Земли по эллиптической орбите"     Case Is < 16.4         MsgBox "Ракета будет способна перемещаться в пределах Солнечной системы"     Case Else         MsgBox "Ракета покинет Солнечную систему"     End Select End Sub
Не нашли ответ?
Ответить на вопрос
Похожие вопросы