Помогите в паскале составить программу даны 3 числа если среди них больше чётных то числа удвойте иначе прибавить к числам 1
Помогите в паскале составить программу даны 3 числа если среди них больше чётных то числа удвойте иначе прибавить к числам 1
Ответ(ы) на вопрос:
Гость
const N = 3;
var a: array[1..N] of integer;
i, x: integer;
begin
x:=0;
for i:=1 to N do begin
read(a[i]);
if a[i] mod 2 = 0 then
x:=x+1;
end;
if 2*x >= N then
for i:=1 to N do begin
a[i]:=a[i]*2;
writeln(a[i]);
end
else
for i:=1 to N do begin
a[i]:=a[i]+1;
writeln(a[i]);
end;
end.
Не нашли ответ?
Похожие вопросы