Помогите выполнить это задание по информатике: Составить программу на языке Паскаль для решения следующей задачи: задать одномерный массив случайным образом и найти сумму элементов с нечётными номерами. Прошу учесть правильнос...
Помогите выполнить это задание по информатике:
Составить программу на языке Паскаль для решения следующей задачи: задать одномерный массив случайным образом и найти сумму элементов с нечётными номерами.
Прошу учесть правильность написания самой программы (Чтобы можно было вставить в паскаль и не исправлять чужие ошибки.(Я ещё в своих не разбираюсь))
Ответ(ы) на вопрос:
const N = 10;
var i, sum: integer;
M: array[1..10] of integer;
begin
sum := 0;
for i := 1 to N do begin
M[ i ] := random(11);
write( M[i], ' ');
if ( M[ i ] mod 2 <> 0 ) then sum := sum + M[ i ];
end;
writeln();
writeln('Сумма всех нечетных элементов: ', sum);
end.
Не нашли ответ?
Похожие вопросы