Построить блок схему и разработать программу на языке Паскаль: Найти площадь окружности, вписанной в равнобедренную трапецию, с основаниями a b и боковой стороной с. Я попытался написать программу, не уверен в правильности. Моя...
Построить блок схему и разработать программу на языке Паскаль:
Найти площадь окружности, вписанной в равнобедренную трапецию, с основаниями a b и боковой стороной с. Я попытался написать программу, не уверен в правильности. Моя ахинея:
const
pi=3.14;
var
figure: byte;
a,b,r,c,f:real;
f:real:=sqrt(a*b)
begin
write(0.5*f);
readln(d);
s:= pi * sqr(d) / 4
end.
Ответ(ы) на вопрос:
Program n1;
var b,c: real;
begin
write('введите верхнее основание: ');
readln(b);
write('введите нижнее основание: ');
readln(c);
writeln('площадь вписанной окружности: ',sqr((sqrt(b*c)/2))*pi:6:2);
end.
Не нашли ответ?
Похожие вопросы