Пожалуйста помогите! Написать программу на Паскале, вычисления суммы S квадратов четных и кубов нечетных чисел от 1 до N. Проверку числа на четность осуществить с помощью встроенной функции ODD.
Пожалуйста помогите!
Написать программу на Паскале, вычисления суммы S квадратов четных и кубов нечетных чисел от 1 до N. Проверку числа на четность осуществить с помощью встроенной функции ODD.
Ответ(ы) на вопрос:
const
n = 3;
var
s,i : integer;
begin
for i := 1 to n do
if odd(i) then
s := s + i * i * i
else
s := s + i * i;
writeln (s);
end.
Не нашли ответ?
Похожие вопросы